Школа физики

Школа физики

Персональный сайт учителя физики
Лях Владимира Петровича

Среда, 24 сентября 2014 00:00

1С-Предприятие. Как поменять местами значения реквизитов в иерархическом справочнике

Автор
Оцените материал
(6 голосов)

Вчера встала задача изменить данные в справочнике. Конкретнее, поменять местами значения двух реквизитов.

Задача осложнялась тем, что справочник иерархический, а модифицировать данные требовалось только в одной группе справочника. Получился вот такой код. Возможно, кому-то пригодится.

&НаКлиенте
Процедура Взаимозамена(Команда)

ЗаменитьНаСервере();

КонецПроцедуры



&НаСервере
Процедура ЗаменитьНаСервере()

Запрос = Новый Запрос;
Запрос.Текст = 
"ВЫБРАТЬ
| Компьютеры.Ссылка,
| Компьютеры.Наименование,
| Компьютеры.Имя
|ИЗ
| Справочник.Компьютеры КАК Компьютеры
|ГДЕ
| Компьютеры.Родитель = &Родитель";

ПолеВводаРодитель = Справочники.Компьютеры.НайтиПоНаименованию("СистемныеБлоки");

Запрос.УстановитьПараметр("Родитель", ПолеВводаРодитель);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать(); 

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

КомпССылка = ВыборкаДетальныеЗаписи.Ссылка;
КомпОбъект = КомпСсылка.ПолучитьОбъект();
РеквизитНаим = КомпОбъект.Наименование;
РеквизитИнв = КомпОбъект.Имя;
КомпОбъект.Наименование = РеквизитИнв;
КомпОбъект.Имя = РеквизитНаим;
КомпОбъект.Записать();

КонецЦикла;

КонецПроцедуры
Донец 14

Выпускник школы

Комментарии   

+2 #2 Донец_14 04.10.2014 11:02
Цитирую Павел:
Код работает нормально. Но не лучше ли использовать метод "НайтиПоКоду"? Ведь наименование может дублироваться

Да, так будет лучше. Спасибо! :-)
Цитировать
+3 #1 Павел 24.09.2014 10:51
Код работает нормально. Но не лучше ли использовать метод "НайтиПоКоду"? Ведь наименование может дублироваться
Цитировать

Комментарии

  • Евгений Евгений 25.11.2017 16:51
    Наконец то Урок по всем современным требованиям. Мугамба доволен!!!!!!!!! Не просто СПАСИБО! А ...

    Подробнее...

     
  • Олег Олег 02.11.2017 16:17
    Владимир, а где сегодня можно купить омагничиватель воды СО-2 или СО-3?

    Подробнее...

     
  • Тимур Тимур 22.09.2017 08:36
    Доброго времени суток, на вашем сайте наткнулся на фотографию учебного вольтметр-термо метра ...

    Подробнее...